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Now that you've switched from Microsoft® Excel® to G Suite, learn how to 
use Google Sheets as your new spreadsheet program.
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Microsoft Excel Google Sheets

Collaboration only in Excel Online Collaborate in real-time from Sheets

Share using email Share directly from Sheets or by email

Save using the File menu Save automatically to Drive

Add multiple tabs to a spreadsheet Add multiple sheets to a spreadsheet

Manage versions with version control (Excel 
Online only)

Manage versions with version history

Add formulas and use Formula AutoComplete 
for suggestions

Add formulas and use formula suggestions that appear as you 
enter text

Record macros or use VBA Record macros or use Google Apps Script

Create filters Create filters and filter views

Create pivot tables manually Create pivot tables manually or automatically with Explore

Create charts manually Create charts manually or automatically with Explore

See recent activity See the activity dashboard

Create notifications using conditional 
formatting

Create notification rules



Access
Sheets

1.1 Get Sheets on your devices

1.2 (Optional) Add multiple Google Accounts

1.3 Create a browser bookmark

1.4 Add a Sheets desktop shortcut (Windows only)

1.5   Work offline (Chrome only)

1
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You can open Sheets in any of the following ways:

● Any web browser—Go to sheets.google.com.
● Google Drive—Click New > Google Sheets and create from scratch or from a template.
● Most Google pages—In the upper-right corner, click the App Launcher      > Sheets.
● Android devices—Install and open the Android app.
● Apple® iOS® devices—Install and open the iOS app.

5

Access Sheets

http://sheets.google.com
https://play.google.com/store/apps/details?id=com.google.android.apps.docs.editors.sheets
https://itunes.apple.com/app/google-sheets/id842849113


Have multiple Google Accounts? Quickly switch between 
them with Chrome profiles.

Note: Don’t have Chrome Browser yet? See instructions on how to install 
Chrome.

1. In Chrome Browser, in the top-right corner next to the 
address bar, click your profile image.

2. Click Manage People.
3. Click Add Person.
4. Enter a name, choose an image, and click Add.
5. Sign in with the Google Account you're adding. 

All settings and bookmarks automatically sync.
6. Click your profile image and choose a different profile 

to switch between accounts.

If you’re unsure which account you’re currently using, click 
your name and see which profile is at the top.
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https://support.google.com/chrome/answer/95346
https://support.google.com/chrome/answer/95346


1. In Chrome Browser, open Sheets. 
Note: If you prefer to open spreadsheets from Google Drive, open Drive instead.

2. In the top-right corner, click More     > Bookmarks.
3. Make sure that Show Bookmarks Bar has a check next to it.
4. In the address bar, click Bookmark     . 

 If you’re not using Chrome, follow your browser’s instructions to bookmark sheets.google.com.
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https://sheets.google.com
https://drive.google.com


If you’re using Microsoft® Windows®, you can add a shortcut to Sheets on your desktop.

1. Go to your desktop and right-click.
2. Choose New > Shortcut.
3. For the location, enter https://sheets.google.com.
4. (Optional) To name your shortcut, enter a name.
5. Click Finish.
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When you turn on offline access in Sheets, your most recent files are automatically saved for offline 
use.

Sheets: Set up offline availability (one time only)

1. Make sure you have the Google Docs Offline extension.
a. Open Chrome Browser and in the top-right corner, click More     > More Tools > 

Extensions.
b. Search for the Google Docs Offline extension.
c. If you don’t have it, open the Google Docs Offline extension and click Add to Chrome.

2. In Drive, click Settings       > Settings.
3. In General, next to Offline, check the sync offline box.
4. Click Done.

Make a specific file available offline:

1. Open Sheets and right-click the file you want to use offline.
2. Turn on Available offline.
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https://chrome.google.com/webstore/detail/google-docs-offline/ghbmnnjooekpmoecnnnilnnbdlolhkhi
https://drive.google.com
https://sheets.google.com


Best 
practices 

2.1  Work with Excel files in Drive

2.2  Use Excel and Sheets together

2.3  Import Excel data into Sheets 

2.4  Convert Excel files to Sheets

2.5  Convert Sheets files to Excel

2.6  Edit Excel files in Drive (without Office)

2
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Best practices

There are different ways to work with Excel files. You can: 

● Import Excel data into Sheets. Learn more
● Convert Excel files to Sheets. Learn more
● Edit Excel files in Drive without converting them. Learn more
● Convert Sheets files to Excel or other formats. Learn more
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Best practices

If your team uses Excel and Sheets, here are some best practices for when to use each product.

Convert existing Excel spreadsheets to Sheets if:

● You need to collaborate or simultaneously edit with your team.
● Your dataset is 5 million cells or fewer.

Continue working in your existing Excel spreadsheets if:

● Your dataset is greater than 5 million cells.
● You’re using the Hyperion add-on with Excel.
● If you use rare chart types, such as 3D pyramid charts or pie-of-pie charts.
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Best practices

You can import data from an Excel file to a new (or 
existing) Sheets file. Your Excel file won’t be changed, 
even as you change the Sheets file. 

Sheets: Import Excel data

1. In Sheets, create a new or open an existing 
spreadsheet.

2. Click File > Import.
3. Choose the Excel file and click Select.
4. Choose an import option:

● Create a new spreadsheet
● Insert as a new sheet in the existing 

spreadsheet
● Replace the existing spreadsheet

5. Click Import data.
6. If prompted, click Open now.

https://sheets.google.com
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Best practices

Instead of importing data, you can convert an Excel file to Sheets and keep working on it in 
Sheets. Your Excel file won’t be changed. 

Sheets: Convert Excel files to Sheets

1. Open Drive and click New > File upload. 
2. Select your Excel file and click Open. Your file will be uploaded to Drive.
3. Right-click the file and select Open with > Google Sheets.

Your file will be converted to Sheets. You might see small formatting differences.

In Drive, you’ll see the Excel file and the new Sheets file. You can keep the Excel file or delete 
it. If you keep the Excel file, to avoid confusion, you can rename it to something like 
[Archived] My doc.xls.  

Tip: Use these icons to quickly differentiate Sheets and Excel files in Drive: 

Sheets Excel

https://drive.google.com
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Best practices

You can work on a spreadsheet in Sheets and then send 
a copy by email as an Excel file (or a PDF).

Sheets: Convert Sheets files to Excel

1. In Sheets, click File > Email as attachment.
2. Under Attach as, choose Microsoft Excel.
3. Enter the email address, subject, and message.
4. (Optional) To email a copy to yourself, check the 

Send a copy to myself box.
5. Click Send.

You can also download a copy of the Sheets file in Excel, PDF, CSV, ODS, or other formats. 

1. In Sheets, click File > Download as.
2. Select the file format you want to download.

https://sheets.google.com
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Best practices

With Drive, even if you don’t have Microsoft® Office®, you can open an Excel file from 
Drive. Any changes you make get saved in the original Excel format. 

You can do this only in Chrome Browser on Windows. 

Sheets: Edit Excel files in Drive

1. Install the Office Editing for Docs, Sheets & Slides Chrome extension.
2. Open Drive and then open an Excel file. 
3. The file opens in Docs, Sheets, or Slides, but keeps the Excel extension. All 

changes are saved in Excel.

http://goo.gl/4rs8ts
https://drive.google.com


Manage data 3.1  Perform basic operations

3.2  Search for data

3.3  See changes to data

3.4  Restrict data sharing

3.5  Use keyboard shortcuts

3
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Manage data

Most basic operations work the same way in Sheets and Excel, such as:

● Moving rows and columns
● Adding or removing rows or columns
● Adding functions (function names are the same)
● Printing spreadsheets
● Copying and pasting data



19

Manage data

  Excel: Find and select Sheets: Find and replace

1. In Sheets, open the file and click Edit > Find and replace.
2. Enter the word you want to find. 
3. (Optional) To replace the word, enter the new word.
4. (Optional) To narrow your search, specify:

● Where to search (all sheets, this sheet, a specific range).
● How to search (match case, match the entire cell, use 

regular expressions, or search in formulas).

5. Click Find, Replace, or Replace All.

https://sheets.google.com
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Manage data

Sheets: Version history and activity stream

Version history shows who made changes (and when) to a 
spreadsheet. 

1. In Sheets, open the file.
2. Click File > Version history > See version history.

The Activity stream shows who commented, edited, moved, or 
shared a spreadsheet. 

1. Open Drive and single-click a spreadsheet to select it.
2. At the top right, click View details      .
3. Click Activity.

  Excel: Track changes

https://sheets.google.com
https://drive.google.com
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Manage data

Sheets: Restrict sharing options

1. In a spreadsheet you own, click Share.
2. Click Advanced.
3. Check one or both of these boxes:

● Prevent editors from changing access and adding new people
● Disable options to download, print, and copy for commenters and viewers

4. Click Save changes.
5. Click Done.
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Manage data

Sheets: See a complete list of shortcuts

1. Open Sheets.
2. For Windows and Chrome OS, press Ctrl+/.
3. For Mac, press ⌘+/.

For more details, see Keyboard shortcuts for Google Sheets.

https://sheets.google.com
https://support.google.com/docs/answer/181110


Analyze data 4.1  Add charts

4.2  Get automatic charts

4.3  Add charts to Docs and Slides

4.4  Functions in Sheets and Excel

4.5  Add pivot tables

4.6  Get automatic pivot tables

4
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Sheets: Add a new chart 

1. In a spreadsheet, highlight the range of data that you 
want to create a chart for.

2. Click Insert > Chart.
3. (Optional) To customize the chart, click More     > Edit 

chart.

You can also add a Sheets chart to a Slides presentation. 

For details about adding charts, see Add and edit a chart or 
graph.
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  Excel: Insert charts

 

Analyze data

https://gsuite.google.com/learning-center/tips/slides/#!/show-tip/quickly-insert-and-update-charts-in-your-presentations
https://support.google.com/docs/answer/63824
https://support.google.com/docs/answer/63824


Get summaries and charts of your data with the click of a 
button in Sheets. It’s kind of like having an expert in data 
analysis sitting next to you.

Sheets: Get automatic charts

1. In a spreadsheet, select a range of cells, columns, or 
rows. Otherwise, you’ll get insights based on where your 
cursor is.

2. At the bottom, click Explore      .
3. Choose an option:

● Point to a chart and click Insert chart       . 
● Ask a question about your data under Answers. 

The results can include charts. To add one, point 
to it and click Insert chart      .

Tip: To customize a chart, click More     > Edit chart > 
Customize.
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Analyze data

  Excel: Copy and paste Sheets: Copy and paste 

Help people visualize data in a presentation or document by adding charts 
from Sheets. If the source data changes, you can update the chart with the 
click of a button.

1. In Sheets, open the spreadsheet and in the chart, click More     > 
Copy chart.

2. In Docs or Slides, paste the chart.
3. Choose an option:

● To update the chart if the source data changes, keep Link to 
spreadsheet selected. Then, if source data changes, at the top 
of the chart, click Update.

● To keep the chart unlinked (not updated), select Paste 
unlinked.

4. Click Paste.

https://docs.google.com
https://slides.google.com
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Analyze data

Most Excel functions are the same in Sheets. For a 
list of common functions, see the Sheets Cheat 
Sheet.

Some unique functions in Sheets: 

● FILTER—Returns a filtered version of the 
source range, returning only rows or columns 
that meet specified conditions.

● SORTN—Returns a specified number of items 
in a data set after a sort.

● SPARKLINE—Creates a miniature chart in a 
single cell.

● QUERY—Runs a Google Visualization API 
Query Language query across data.

● GOOGLEFINANCE—Gets current or historical 
securities information from Google Finance.

● GOOGLETRANSLATE—Translates text from 
one language into another.

● IMPORTRANGE—Imports a range of cells from 
a specified spreadsheet.

For a list of all functions in Sheets, see the Google 
Sheets function list.

https://gsuite.google.com/learning-center/products/sheets/cheat-sheet/#!/
https://gsuite.google.com/learning-center/products/sheets/cheat-sheet/#!/
https://support.google.com/docs/table/25273
https://support.google.com/docs/table/25273
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Analyze data

  Excel: Insert a PivotTable Sheets: Add a new pivot table

1. Highlight data in your spreadsheet.
2. Click Data > Pivot table. A pivot table opens in a new sheet (tab).
3. In the Pivot table editor, add rows, columns, values, and filters.

For details, see Create & use pivot tables.

https://support.google.com/docs/answer/1272900
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Analyze data

  Excel: Insert a PivotTable Sheets: Get automatic pivot tables

1. In your spreadsheet containing the source data, click Explore      . 
2. Choose an option:

● Point to a pivot table and click Insert pivot table       . 
● Ask a question about your data under Answers. The results 

can include pivot tables. To add one, point to it and click 
Insert pivot table       .

For details, see Create & use pivot tables.

https://support.google.com/docs/answer/1272900


Use macros 
and add-ons

5.1  Automate tasks with macros

5.2  Do more with add-ons
5
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Sheets: Macros and Google Apps Script

Automate repetitive tasks with macros in Sheets. Or, if you need 
custom functions, menus, or windows, you can create them with 
Google Apps Script.

Record a macro:

1. In Sheets, open a spreadsheet and click Tools > Macros > 
Record macro.

2. Select the type of cell reference to use.
3. Complete the task you want to record and click Save.
4. Name the macro and click Save.
5. Click Tools > Macros > your macro to run the macro.

    Excel: Record Macro
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Use macros, add-ons, and scripts

Create a script:

1. Click Tools > Script editor.
2. Create your script.

For more information, see 
Overview of Google Apps Script.

https://sheets.google.com
https://developers.google.com/apps-script/overview


    Excel: Add-ins
  

Sheets: Add-ons

Use ready-made add-ons to do more with Sheets. Here’s a few things you 
can do:

● Use the Data connector for Salesforce to connect with Salesforce.
● Use Supermetrics to connect with MySQL and Oracle.
● Use Copper CRM Custom Report Builder to integrate Copper CRM 

data.
● Use Greenhouse Report Connector to integrate Greenhouse 

recruiting data.
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Use macros, add-ons, and scripts

Download add-ons:

1. Click Add-ons > Get add-ons.
2. (Optional) To see a description of the add-on, point to it or click it 

for a full description.
3. Click the add-on you want to install and click Free.
4. If needed, review the access message and click Allow.

https://chrome.google.com/webstore/detail/data-connector-for-salesf/jijmhhpjhgeafilgjkdeocjepoacekof?utm_source=permalink
https://chrome.google.com/webstore/detail/supermetrics/bnkdidgbiidpnohlnhmkehlimlnfhgce?utm_source=permalink
https://chrome.google.com/webstore/detail/copper-crm-custom-report/bcbdocneacmnhkpdekkjjbeajeblmmhd?utm_source=permalink
https://chrome.google.com/webstore/detail/greenhouse-report-connect/cimiindgenpkloholhafijbdgkjbncpl?utm_source=permalink


Collaborate 6.1 Share spreadsheets

6.2 Add comments and assign tasks

6.3 Email collaborators

6.4   Switch to an earlier version or name a version

6.5 Create filters and filter views

6.6   Protect content

6.7   Limit sharing, downloading, printing, or copying

6.8   Set an expiration date for sharing

6.9   See who’s viewed a spreadsheet

6

Switching to Sheets from Microsoft Excel 33

#
#


  Excel: Share workbook Sheets: Share with specific people or using a link

Share with specific people:

1. Open the file you want to share (that you own or have 
edit access to).

2. Click Share.
3. Enter the email addresses or groups that you want to 

share with.
4. Choose what kind of access you want to give people: 

Can edit, Can comment, or Can view.
5. Click Send.

Share using a link:

1. Open the file and click Share.
2. At the top right, click Get shareable link.
3. Next to Anyone with the link, click the Down arrow     and 

choose the level of access you want to give people.
4. Copy and paste the link in an email or any place you 

want to share it.

For more details, see Share files from Google Drive.
34
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https://support.google.com/drive/answer/2494822


  Excel: Send Using E-mail Sheets: Email collaborators

To follow up on a conversation that’s too long for 
comments, email collaborators right from Sheets.

1. Click File > Email collaborators.
2. (Optional) To remove a collaborator from the email, 

uncheck the box next to their name. 
3. Add a subject and message.
4. (Optional) To send a copy of the email to yourself, 

check the Send a copy box.
5. Click Send.
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Collaborate

If you own the spreadsheet or have edit access to it, you can see 
past versions and restore them.

Sheets: See versions or restore a version:

1. Select File > Version history > See version history.
2. (Optional) To see only named versions in the list, click 

Only show named versions.
3. Click a timestamp to see a previous version of the file. 

Below the timestamp, you’ll see:

● The names of anyone who edited the document.
● A color next to each person’s name. The edits 

they made appear in that color.

3. (Optional) To make the version the active version, click 
Restore this version.

Name a version:

1. Select File > Version history > Name current version.
2. Enter a name and click Save.



  Excel: Filter data Sheets: Filters and filter views

To filter out data in a spreadsheet, create a filter. If you want 
filters that don’t affect anyone else’s view, create filter views.

Create a filter:

1. Select a range of cells.
2. Click Data > Create a filter.
3. Go to the top of the range and click Filter     to see the filter 

options.
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Create a filter view:

1. Click a cell that has data.
2. Click Data > Filter views > Create new filter view.
3. In a column header, click a list and select the data you want to filter. Or, in the search box, 

enter text to search for the data you want to filter.
4. Click OK.
5. In the Name box, enter a name for your filter view.
6. Click Data > Filter views to open your filter view anytime.

 For more information, see Sort & filter your data and Create, name, and save a filter view. 

https://support.google.com/docs/answer/3540681
https://support.google.com/docs/answer/3540681#filter_view


  Excel: Protect Sheet or Workbook
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Collaborate

Sheets: Protected sheets and ranges

If you have sensitive content in a spreadsheet, you can 
restrict people from updating it.

1. Open the sheet and click Data > Protected sheets and 
ranges.

2. Click +Add a sheet or range.
3. Click Range to protect a range of content or Sheet to 

protect a whole sheet.
4. Click Set permissions and choose whether to show a 

warning or restrict who can edit the content.
5. Click Done.

For details, see Protect content in a spreadsheet.

https://gsuite.google.com/learning-center/tips/sheets/#!/show-tip/protect-content-in-a-spreadsheet
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Collaborate

  Excel: Encrypt with Password Sheets: Limit sharing options

If you have sensitive content in a spreadsheet, you 
can prevent people from downloading, printing, or 
copying it.

1. At the top of the spreadsheet, click Share.
2. At the bottom, click Advanced.
3. Check the Disable options to download, print, & 

copy for commenters and viewers box.
4. Click Done.
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Collaborate

Sheets: Set sharing expirations

When you’re working with people outside of your organization, such as clients or agencies, you 
might want to restrict their access to certain files when your projects are complete.

Set an expiration date:

1. At the top of the spreadsheet, click Share.
2. If the file isn’t already shared, share it.
3. Click Advanced.
4. Hover over a person’s name and click Set expiration      .
5. Change the access expiration date.
6. Click Save changes > Done.

Note: You can’t set the expiration for the current day. If you need to restrict access immediately, 
just unshare the file.



In Sheets, if you have edit access to a spreadsheet, you can see:

● Who it’s shared with
● Who viewed it
● A chart of viewers over time

 To see the Activity dashboard, at the top right, click Activity dashboard       . 

If you don’t want your view history to appear in the Activity dashboard, you can change the privacy 
settings.
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Export 
spreadsheets

7.1 Print spreadsheets

7.2 Download in different formats

7.3 Make a copy

7.4 Email a copy

7
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  Excel: Print Sheets: Print

To print your spreadsheet, click File > Print or Print       .

You can choose which sheets to print, what features to 
include, and which layout you want.
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  Excel: Save As Sheets: Download

To download your spreadsheet so you can open it in other programs, 
click File > Download as and choose one of the following formats:

● Microsoft Excel (.xlsx)
● OpenDocument format (.odt)
● PDF document (.pdf)
● Web page (.html, zipped)
● Comma-separated values (.csv)
● Tab-separated values (.tsv)
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  Excel: Copy a sheet Sheets: Make a copy

Copying a spreadsheet is useful for creating templates. For example, 
if you write a lot of project plans, make copies of one plan. Then, 
update each copy for a new project without having to format it again.

To make a copy of your spreadsheet, click File > Make a copy. You 
can rename the copy, change where you save it in Drive, and 
optionally share it with the same collaborators.

45
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Export spreadsheets

  Excel: Send Using E-mail Sheets: Email as attachment

If you need to collaborate with someone on your spreadsheet in your 
old program or format, such as PDF or Excel, you can email it as an 
attachment.

1. Open the spreadsheet and click File > Email as attachment.
2. Select a format.
3. Enter the email addresses or groups you want to send copies to.
4. Add a message.
5. Click Send.



Productivity 
tips

8.1   Import data from Forms

8.2   Save time with templates

8.3   Find out if someone changes a spreadsheet

8.4   Add checkboxes to cells

8
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Analyze data from Google Forms by sending it to Sheets.

1. In Forms, open the form with the data you want to import.
2. At the top, click Responses.
3. Click More     > Select response destination.
4. Create a new spreadsheet or select an existing one.
5. Click Create or Select.

48
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https://forms.google.com


If you’re creating the same types of files over and over, such 
as expense reports and purchase orders, save time with a 
template.

Sheets: Choose an existing template:

1. Open Sheets and at the top, click Template Gallery.
2. Click the template you want to open it.

Create your own template:

1. Open Sheets and at the top, click Template Gallery.
2. At the top of the gallery, click your organization’s 

name.
3. Click Submit Template.
4. Click Select a spreadsheet, and choose the template 

file you created, and then click Open.
5. Select a category for your file.
6. Click Submit.

Your new template appears in the Template Gallery under 
your organization’s name.

Productivity tips

48

https://sheets.google.com
https://sheets.google.com
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Productivity tips

Notification rules let you know when any changes are made to a spreadsheet.

Sheets: Create notification rules:

1. In Sheets, open the spreadsheet where you want to set notifications.
2. Click Tools > Notification rules.
3. Select when and how you want to receive notifications.
4. Click Save.

https://sheets.google.com
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Productivity tips

Use checkboxes to make Sheets more interactive. You can use checkboxes with charts, filters, 
pivot tables, and formulas.

Sheets: Add or remove checkboxes:

1. In Sheets, open a spreadsheet and select the cells where you want checkboxes.
2. Click Insert > Checkbox.

Note: In formulas, unselected checkboxes have a value of FALSE (exclude) and selected 
checkboxes have a value of TRUE (include). You can see the value in the Formula bar. 
You can also change this value.

3. (Optional) To delete checkboxes, select the checkboxes you want to remove and press 
Delete.

https://sheets.google.com
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1. Help us improve this guide:

2. Get more training resources at the G Suite Learning Center 
(gsuite.google.com/learning-center), such as:

■ Cheat sheets

■ Product FAQ

■ Productivity tips

■ Customer examples

Visit the Learning Center

Next steps

Submit feedback

https://gsuite.google.com/learning-center/
https://goo.gl/zyW8fd

